原です。

> ふなばです。

> nonzero? という名前がダサいと思ったことはありません。そういうことを考

いやっ、ダサいというのは、見た目かっこいいと感じないという極めて
情緒的な主観を、いまどきの若者風を気取って表現しただけですの
で、お気になさらないでください。:-)

> nonzero? という名前がダサいと思ったことはありません。そういうことを考
> えたこともないです。たぶん、僕は、原さんやごとけんさんほど、nonzero?
> に評価してないのでしょう。

nonzero? という名前について感じるのは、(a)もっと短くならないかな
(b)non という否定の接頭辞を持たない表現はないかな(c)zeroだけ
特別扱いしてるな、です。代案は無いんですけどね。(^^;

そうですね。私の方が nonzero? を評価しているからそういう発言を
してしまうのですね。

> 以前に、どうして Ruby は、零を偽としてあつかわないのか、偽としてあつかっ
> たらどうか、という話を聞いたような気がします。僕は <> や ||| などの提
> 案は、これの変形にすぎないと思っています。
> 
> この解釈が正しいのかどうか判りませんが、そう思っているので、僕には、ど
> うしても不純な動機をもったものに感じられます。

それが不純であるという感覚を、私も共有しています。nonzero? という名
前には、それには non-zero という意味しかないんだよという主張があり、
その点で好感を持ちます。non という演算子の提案はさらに zero を切り
離して zero が特別な意味を持つという不純さを逃れようとしての事です。

> そういう考えですから、僕はなにかやるにしても、メソッドで対応するくらい
> が相応しいと思っています (Ruby 自身がダサくならないように)。

しかしそいうメソッドが存在すること自体が零を特別扱いする事になりま
すよね。nonunit?, nontwo?, nonthree? とか必要になりそうで不安、、、で
もないか。じゃあ、fixed_element_additively? という名前はどうか。さらに
長いって。

<=> で複数の要素を比較する話にもどると、Ruby 的は配列で評価する
のがきれいなんですが、全ての要素を評価してから比較するのはコスト
高なので、なんとかならないか、or の様な評価を途中で打ち切る仕組み
を持てないか?というのが今のテーマですが、いい案で出ないなあ。
case - when 的な文法になるしかないのかな。