原です。

In message "[ruby-list:17733] Re: <=>"
    on 99/10/16, Tadayoshi Funaba <tadf / kt.rim.or.jp> writes:

|で、どういうのがよかったわけ?
|
|ふなば ただよし

前にも同じ事を言ってしまったんですが、色々考えてもいい案は無いです。
短ければよかったなあと思うばかりで。(^^;


話はちょっと変わるけど、non という演算子を用意して x.nonzero? を 
x non 0 と書けるとどうでしょう?左辺が右辺に等しければ false そう
でなければ左辺。

  (a <=> b).nonzero? or
  (aa <=> bb).nonzero? or
  (aaa <=> bbb)

が

  a <=> b non 0 or
  aa <=> bb non 0 or
  aaa <=> bbb

ですか、、、これはイマイチだけど、

  if x != 0 and x != "" then x else false end

が

  x non 0 non ""

とフィルタみたいに書けるのはいいな。