ruby ユーザの皆様初めまして.
林@大阪産業大学(情報科学センター)と申します。

postgres-0.5.3 を利用しようとして
アーカイブを展開し, extconf.rb を起動させると
以下のような形になり makefile が作成されません.

> ruby extconf.rb
checking for cygwin32_socket() in -lwsock32... no
checking for socket() in -lsocket... no
checking for gethostbyname() in -linet... no
checking for gethostbyname() in -lnsl... no
checking for sys/un.h... yes
checking for socket()... yes
checking for hsterror()... no
checking for gethostname()... yes
checking for PQsetdbLogin() in -lpq... no
> ls
MANIFEST                extconf.rb              postgres.jp.html
README                  postgres.c              psql.rb
README.jp               postgres.html           psqlHelp.rb

OS は FreeBSD3.2-STABLE
ruby のバージョンは 1.4.2 を使っています.
ruby-1.4.2 は 最新の ports に 1.4.0 しか無かったので
makefile の 1.4 を 1.4.2 変更し patch ファイルを削除
してインストールしました.

postgre関係の環境変数は

POSTGRES_HOME=/usr/local/pgsql
PGLIB=/usr/local/pgsql/lib
PGDATA=/usr/local/pgsql/data
LD_LIBRARY_PATH=/usr/local/pgsql/lib

になっています.

どうか,よろしくお願いします.

---
Kazumi Hayashi(林 かずみ)                              __o   
E-Mail: kazumi / cnt.osaka-sandai.ac.jp               _ |<._    
        kazumi13 / ceres.dti.ne.jp           ........(_)/ (_)    
                                   _/__/_/__/_/__/_/__/_/__/