原です。

In message "[ruby-list:17724] Re: <=>"
    on 99/10/15, Koretsugu Daigoro <tmmcross / hk.airnet.ne.jp> writes:
|
|これつぐです。

|> # これつぐさんの[ruby-list:17702]に対する反論でした
|
|うーん、「反論」と構えて反論されるほど
|変なことを言っているつもりはなかったんですが、
|こういう感覚は私独自のものなんでしょうか?

私も -1, 0, 1 というのは、このままでいいと思います。てんびんに
のせて目盛を読むノリで。(a <=> b が左辺が右辺に比べてどのぐら
い重いかという Float を返してくれてもいいかも。:-))逆に、0 が
false や nil になるのは、不自然な気がする。

 (a <=> b).nonzero? || aa <=> bb

というのも、本質的にこれでいいのでは。あえていえば nonzero? と
いうメソッド名がださい。(^^;