青山です。

On Thu, 14 Oct 1999 17:26:05 +0900,
Tadayoshi Funaba <tadf / kt.rim.or.jp> wrote:

> だいたい、-1, 1 もこれが適切とは言いきれません、といっていますよね。

2つの問題を混ぜてしまい(分けてしまい)すみません。この -1, 1 というの
は、|| でつなげると便利という話とは別で、<=> の返り値は、数値ではなく
(ちょうど何人かの方が書いて下さいましたが)、great, equal, less のような
物にすべきかもしれないというつもりでした。

つまり、().nonzero? || ().nonzero? || ... というのは美しく無いので、
数値である必要がないならば、0 など返さずに nil, false 等を返すようにし、
nonzero? を使わずに済むと嬉しい。

という話と、

-1, 0, 1 というのは C 等での慣習であり、きっと数値である必要はないだろ
うから、great, equal, less のような物にすべきかもしれない。

という話です。

話をおかしくしてしまったのは私でした。申し訳ありません。後者の話を別に
して前者の話だけをするのは問題がありましたね。

まとめると、ちょうど [ruby-list:17679] の、かんださんの案のような感じ
です。

-----
今回は一人でかなり外れた所を行ってしまいました。Perl を使い込んでしまっ
ていた事がこんな所で影響するとは。


-- 
青山 和光 Wakou Aoyama <wakou / fsinet.or.jp