えぐち@エスアンドイー です。

>>> In message [ruby-list:17641] Re: <=> (Re: Hash $B$K(Bnil$BCM$rF~$l$?$J$i(B)
    On Tue, 12 Oct 1999 21:42:08 +0900, Tadayoshi Funaba <tadf / kt.rim.or.jp> said:

tadf> ふなばです。
tadf> 
tadf> At 1999-10-12T20:39:49+0900 (2451463.98598JD),
tadf> eguchi / shizuokanet.ne.jp (EGUCHI Osamu) wrote:
	...
tadf> eguchi> 問題は、記号なんですけど、、
tadf> 
tadf> eguchi> 	a.to_i <=> b.to_i ||| a.to_s <=> b.to_s
tadf> 
tadf> 僕も <=> の仕様変更はムリがあるように思います。で、これだけなら、
tadf> 
tadf> (a.to_i <=> b.to_i).nonzero? || a.to_s <=> b.to_s
tadf> 
tadf> でもよさそうなので、あたらしい演算子を導入する理由も、少し弱い気がしま
tadf> すです。

ですが、これだと nonzero? が -1/false/+1 でなく true/false/true
を返して芳しくないですね。

#確かに、これだけで演算子を新たに導入するには、理由が弱いというのは同感 ^^;;

	えぐち