ふなばです。

At 1999-10-12T20:39:49+0900 (2451463.98598JD),
eguchi / shizuokanet.ne.jp (EGUCHI Osamu) wrote:

eguchi> むしろ新しい演算子として、

eguchi> 	左辺がゼロ以外ならそれを返し、
eguchi> 	左辺がゼロなら右辺を返す2項演算子

eguchi> があれば都合が良く、現状の <=> でもカスケード出来ると思います。

eguchi> 問題は、記号なんですけど、、

eguchi> 	a.to_i <=> b.to_i ||| a.to_s <=> b.to_s

僕も <=> の仕様変更はムリがあるように思います。で、これだけなら、

(a.to_i <=> b.to_i).nonzero? || a.to_s <=> b.to_s

でもよさそうなので、あたらしい演算子を導入する理由も、少し弱い気がしま
すです。

ふなば ただよし