Toshです。

> それならもちろん賛成します。(…なんか偉そう ^^;;)
> ただ、それだとやはり便宜のために強制はしない、省略可能な仕様と
> いうことになると思うんです。それはつまり、RDのスペックの変更では
> なくなります。あとは、拡張しやすいように、RDの細部をつめておけば、
> それでいいのではないでしょうか。
> 
> たとえば、=begin や =end のうしろになにか書いたらどうなるとか、
> 逆に書いてないとどういう意味とか。
> =begin のあとに使える単語の予約をしておいたりすると、後でいいことが
> あるかもしれませんね。とりあえず RD と RD-Header は予約?
> 
> あと、Tosh さんのメールにあったことを考えあわせて、
> =begin \S+ は通常無視するけが、=begin [rR][dD] の場合だけは RD と
> みなすようにするのはどうでしょうか?
> -------------------------------------------------------------------
> あおきみねろう

"=begin foo ... =end"の様な構造はなるべく使いたくないと考えています。
"=begin ... =end"は単にRDとRuby scriptの境界線で、それ以上の意味を持たせる
のはどうか、ってことです。
"=begin foo ... =end"とか"=begin foo="bar" ... =end"みたいなものは簡単に
いろいろ拡張できそうなので便利だとは思いますが、あまりLaTeXの環境やHTMLの
エレメントじみていてRDらしくないと思います。汎用のブロックみたいのは
使いたくないし、HTMLの属性みたいな指定をごちゃごちゃつけるのもやりたく
ないわけです。
ただ、"=begin RD-Header ... =end"は(個人的にはもっと短い方がいいですが。
「HEAD」とか。ハイフン入っているとあったかどうかとかも忘れやすそうですし)
ヘッダみたいなものは必要でしょうし、RDそのものとは違う付加的な情報なんだ
ということをはっきりさせるためにも"=begin RD-Header ... =end"みたいな
形は悪くないとは思います。
だからヘッダだけは特別って言うのでいいんじゃないかと。別に無視しても
たいした問題は起こらないでしょうから、フォーマットがヘッダを解釈でき
ずにコメントとして処理してしまってもまあ大丈夫でしょうし。

---
Tosh