青山です。

On Thu, 19 Aug 1999 16:29:03 +0900,
matz / netlab.co.jp (Yukihiro Matsumoto) wrote:

> 1.4系には入らないでしょうね。

ですよね。

> さて、aliasを作るというwork aroundがあるのでtimeout.rbは修正
> しなくても良いかなあって思ってるんですけど、どう思われます?

alias で対応しようとは思っていますが、require するだけで無条件にトップ
レベルにメソッドが追加されるという仕様は、組み込み関数が少ないという
Ruby のメリットに反しているように感じられ、違和感を感じます。

Kernel モジュールのメソッドは減らそうという動きも何度か出ていますし、
やはり、トップレベルに関しては基本的にはユーザーが定義したもののみにな
るようにした方が見通しも良く、安心感があるような気がします。また、他の
ライブラリに関してもやはり自然とそのようになっているような気がしますし。


-- 
青山 和光 Wakou Aoyama <wakou / fsinet.or.jp>