助田です.
In [ruby-list:15516] Re: Ruby on DOS/V magazine 8/1

> まつもと ゆきひろです

> |Ruby 1.3 の Cygwin32 版では Tcl8.x 系にも対応しています.

> 「にも」ってことはないんじゃないかと。APIが変わってるんでバ
> イナリレベルではどちらかにしか対応できないように思います。
> Windows版ではできるのかしら?

Cygwin32 版では, 7.x 用(tcltklib71.dll)と 8.x 用(tcltklib81.dll)
が用意されていて,環境変数 TCL_LIBRARY をみて
必要な方を require するようになってます.

tcltklib.rb で

require 'tcltklib' + (/8/ =~ ENV['TCL_LIBRARY'] ? '81' : '76')

と書いて適切な方を require してます.

そういう意味で「にも」です.
--------------------------------------------
 助田雅紀(masaki.suketa / systemplaza.co.jp)
--------------------------------------------