こんにちは。鈴木教郎です。

> From: Yasuhiro Fukuma <yasuf / big.or.jp>
> Subject: FreeBSD port kit for some extention modules and applications
> Date: Tue, 20 Apr 1999 02:17:21 +0900
>> Message-ID: <19990420020848A.yasuf / big.or.jp>

>   ruby-gtk-0.16
<snip>
> の、FreeBSD用のport kitを作成しました。

これを -current を持ってないので、2.2.7-RELEASE でためしてみました。せ
めて 3.1-RELEASE で試したかった。

gtk/src/makedefconst.sh の最後に 

echo "  \$(AR) -rs \$@ \$?" >> Makefile

と言うのがありますが、私の ar は、s をオプションに持つことができません
でした。

また、make install すると、

patty# make install
>> Checksum OK for ruby-gtk-0.16.tar.gz.
===>  Installing for ruby-gtk-0.16
===>  ruby-gtk-0.16 depends on executable: ruby - found
===>  ruby-gtk-0.16 depends on shared library: gtk10.1 - found
sh  Init_gtk_gdkkeysyms
Init_gtk_gdkkeysyms: Can't open Init_gtk_gdkkeysyms
*** Error code 2

となってしまいました。実際 次のコマンドを試しましたが、work 以下に 
Init_gtk_gdkkeysyms を見つけることができませんでした。

find . -name Init_gtk_gdkkeysyms -print

# こんなになってしまいましたが、これは -current でないことが原因でした
# ら、無視してください。

> # ある程度数がまとまってきたら、ports collectionに ruby という
> # virtual categoryを作らせてもらいましょう:)

賛成!!
-- 
鈴木教郎
E-Mail: nosuzuki / e-mail.ne.jp