まつもと ゆきひろです

In message "[ruby-list:13907] Re: FW: ruby-1.2.5 mkconfig.rb"
    on 99/04/20, Katsuyuki Komatsu <komatsu / sarion.co.jp> writes:

|>   /usr/bin/installが見つからない
|>   ruby.hが/usr/lib/ruby/cpu-os/ruby.hが見つからない
|>
|> のいずれかの場合だけだと思うのですが,なにか見落としがありま
|> したでしょうか?
|
|Solaris・HP-UXでは、installは、
|    /usr/sbin/install
|ですからその条件にあてはまります。
|インストール時にパスは通してありましたが。

installがbsd installと同じ挙動をするかどうかをチェックして外
しているようです.AIXも同様です.

で,これはどうしたものでしょうね.拡張ライブラリのインストー
ルにはBSD互換のinstallが必要です.んで,いくつかのマシンでは
ソースツリーの中にこれを含んでいます.で,拡張ライブラリだけ
をコンパイルしようとするとこれらのマシンではソースツリーを保
存する必要があると,うーむ.

  (1) installは使わない,全部rubyでインストールする
  (2) install-shも一緒に/usr/lib/rubyにインストールする

のいずれかで対応する必要があるのでしょうか.それとも第三の方
法が?
                                まつもと ゆきひろ /:|)