木村です。

        In article [ruby-list:12920] Re: win32ole
          (<199903162357.IAA10601 / atlanta.sqa.canon.co.jp>),
	  KIMURA Koichi <kimura / sqa.canon.co.jp> writes:

>win32oleに附属の excel[12].rbはWindows 95 + Excel 97および 
>Windows NT 4.0 + Excel 97 で動作するのを確認してます。

補足です。元々のサンプルは Execl Ver5を対象にしているので、

#application = WIN32OLE.new('Excel.Application.5')
application = WIN32OLE.new('Excel.Application')

のように変えています(上の行のスタイルを使う場合には
Excel.Application.8とすればうまく行くと思います(Excel 97の場合))。

-- 
木村浩一
            May the source be with you.
    e-mail kbk / kt.rim.or.jp
           kimura / sqa.canon.co.jp