まつもと ゆきひろです

In message "[ruby-list:12685] Re: alternative name of iterator"
    on 99/03/09, 中村暁史 <anakamur / exa.i-tech.co.jp> writes:

|->|「単に使ってる英単語が同じなだけ」くらいにしか
|->操作できるんだからオブジェクトだと思いますよ.
|
|つーか、兄弟クラスですね。もっと上にナニか「操作できるもの」
|というスーパークラスがあって、その子としてかたやCのobject、
|かたやooのobject、があるというか。

うーん,これは「オブジェクトの定義」という哲学的な問題になり
ますです.ある人は「操作できるもの」をオブジェクトと呼びます
し,別の人は「メソッドを持つもの」をオブジェクトと呼びます.
ま,合意する必要もないんでしょうけど.

|->あるいは可能であっても意味がないかもしれませんね.現実世界で
|->意味があってナンボだと思いますから.
|
|意味がないかどうかは別問題だとは思いますが、
|「人類に観測&実現できない」限界はあるかも知れません(^^;

「意味がない」というのを「Ruby的に意味がない」と読み替えてく
ださい.そういう研究を一生懸命している人に失礼にとれますね.

                                まつもと ゆきひろ /:|)