まつもと ゆきひろです

In message "[ruby-list:12680] Re: alternative name of iterator"
    on 99/03/09, moochan <moochan / ss.hitachizosen.co.jp> writes:

|# 言い訳じゃないけどリファレンスマニュアルも分かり易くならん?

ぐさぐさっ ^^;;;

そーゆーのは青山さんに頼もう.

|でしょうね.バランス,妙に納得させられる言葉だ.
|# 妥協とも近いなあ

ま,そうネガティブにとらないで.バランスはRubyの設計原理のひ
とつです.

|見かけはオブジェクトだが内部は非オブジェクトとと言うのと,その逆では
|どちらがいいのでしょう.
|# ケースバイケースか?

まさにそうだと思います.私はブロックはオブジェクト的に見える
必要はないと判断しました.

|ええ.確かに素晴らしいことは素晴らしいですが,
|
|aBoolean ifTrue: { print "true\n" } ifFalse: { print "false\n" }
|
|みたいなことができたらもっと驚いたかも.

その気になれば

  aBoolean.ifTrue{ print "true\n" }.ifFalse{ print "false\n" }

くらいならできますよ.効率は現実的じゃないですけどね.

|# まつもとさんから難しいなんて言葉がでるとは想像もしなかったなあ.

難しいことはたくさんありますよ.だいたい「分かりやすい」とか
「ドキュメント」とかいう単語と一緒に登場しますね.:-)

|# いつもながらまつもとさんのパワーには「青年力」を感じさせられる
|# 私は中年力,いや老人力だ.(^^;;;

実はそんなに変わらなかったりするんじゃないですか?

確かにLarryよりもGuidoよりも若いですが,前田さんよりはかなり
に年上です.もちろん,今回UNIX USERに登場した小塚くんよりも
はるかに.
                                現役高校生にはかなわない
                                まつもと ゆきひろ /:|)