盛り上がっているところに大変申し訳ないんですが、

> matz> |1.2.3 が出るのであれば、それまでに freebsd2.x.x や sunos4.x.x 
> matz> |のような古いタイプの shared-library でも、 --enable-shared が
> matz> |有効にしてしまおうと思います。
> matz> 
> matz> でます.貢献に感謝します.
> 
> 手を付けましたが、 'libruby.so' と言うフレーズが
> そこかしこに見られるので、うかつな事をすると、
> 他のプラットホームに悪影響が出そうなので、慎重になっています。

これは 1.3 系でやったほうが良いのではないでしょうか。特に他のプラット
ホームに影響が出るのならなおさら。

1.1c 以降、安定版といわれているはずの ruby で、パッチなしで使えるもの
はほとんどなかったです。特に現在の 1.2.2 は FreeBSD3.0 ではインストー
ルすらできない。その前まではできていたのに。

# 偉そうなこといってすみません。しかしこれでは人に ruby すすめられない。

--
================================
T.Hirohisa // thiro / kt.rim.or.jp
================================