福嶋です。

Hiroshi Igarashi <igarashi / ueda.info.waseda.ac.jp> wrote:
> それから、もとのGTKの長い名前も残しておいたほうがいいでしょうか。
> Ruby/GTKの他のメソッド(getter/setter)では
>   1. 元の名前だけ (見付しだい短い名前でも定義している)
>   2. 短い名前だけ
>   3. 両方ある
> が混在してしまっています。
> 清く2に統一してしまうのがいいとは思うのですが、

それでいいんじゃないでしょうか。

> CからGTKを使ってきた人にとってはもとの名前の方が
> 分かりやすいのかなと思って削除まではしていません。

拡張ライブラリレベルでは短い名前に統一しておいて、元の名前を
alias として提供する .rb を付けるというのはどうでしょう。

---
福嶋正機