いがらしです。
反応が遅くなりましてすみません。

「[ruby-ext:00369] Re: Ruby/Gtk + Imlib patch」で 、
NAKAMURA Hi-deki- <deki / yk.rim.or.jp>さんは書きました:

> 仲村です。

> ruby-gtk-SNAPSHOT-19990802.tar.gz へのパッチで送ります。
> 一応、付属のGdkImlibサンプルは、全部動くことを確認しました。
> 修正メモもつけてあります。

ありがとうございます。
スナップショットには取り込んであります。

> ただし、mallocからみでImlibのソースを眺めていたら、Imlibのほうで、メモ
> リ割り当てに失敗したときの対処が考えられていないとこが結構ありました。
> なので、このパッチの修正だけでは完璧ではないです。Imlibを修正した上で
> rbgdkimlib.cを修正しないと。。

Imlib本体の問題はどうしようもないですよね。
あるいは、Imlibの開発者へパッチを送って頂くとか(^_^)

> > それから
> >     http://www.ueda.info.waseda.ac.jp/~igarashi/ruby/api-ja/gtk.html
> > にGdkImlibモジュールとGdkImlib::Imageクラスを追加しておきました。
> > メソッド名で意見のある方はどうぞ。
> 
> これですが、GdkImlib::Image のメソッド名に "image" と入っているものは、
> "image"を省いたメソッド名にしたほうがいいですかね。
> いがらしさんにクラス名を指摘されたあとであらためてメソッド名を眺めてみ
> ると、冗長に感じてしまって。

ではそのようにしましょう。

それから、もとのGTKの長い名前も残しておいたほうがいいでしょうか。
Ruby/GTKの他のメソッド(getter/setter)では
  1. 元の名前だけ (見付しだい短い名前でも定義している)
  2. 短い名前だけ
  3. 両方ある
が混在してしまっています。
清く2に統一してしまうのがいいとは思うのですが、
CからGTKを使ってきた人にとってはもとの名前の方が
分かりやすいのかなと思って削除まではしていません。

ご意見お待ちしております。

----
五十嵐  宏  (Hiroshi IGARASHI)