初めまして
 先週あたりからrubyをいろいろと試しています。いままではPerlを使用してい
ました。
 postgreSQLの拡張モジュールの件でお尋ねします。以下のページから拡張モジュー
ルをダウンロードしてインストールしたのですがPQserverVersion関数がないた
めにエラーになります。PQserverVersionはpostgreSQL7.4には実装されていない
ためエラーになっているので、postgres.cを編集してPQserverVersion関数呼び
出しをコメントアウトしたところSELECT_ONEのテストで正常動作するようになり
ました。

 http://ruby.scripting.ca/postgres/
 ruby-postgres-20051221.tar.gz

 とりあえずは動いたのですがこれでよいのでしょうか。

 以下のファイルも試してみたのですが、インストーラがWindows用にできてい
るようでした。
  ruby-postgres-0.7.1.tar.gz

 インストール方法はrootで
ruby extconf.rb
make
make install

 postgreSQL 7.4
 ruby 1.8.4
 redhat linux 9

システムアート研究所 中西 健

--------------------------------------
Celebrate Yahoo! JAPAN 10th Anniversary
http://pr.mail.yahoo.co.jp/10thann/