こんにちは、なかむら(う)です。

In message "[ruby-ext:02183] Re: C++の可変引数の取り扱い"
    on Jun.03,2003 11:05:04, <nobu.nakada / nifty.ne.jp> wrote:
| > 環境
| > C++Builder6
| > WindowsXP
| > Ruby1.6.8(mswin32)
| 
| 1.8ならBCCはサポートされてますが、1.6.8だと問題が出るかも知れま
| せん。少なくともmkmf.rbは対応してないですし。シンボルのprefixで
| VCとは互換性がない、という話もあります。

正直、mswin32版とBCCという組み合わせはいろいろつらいので、
bccwin32版の利用を検討されることをお勧めします。
# シンボルのprefixとか、ruby DLLとのリンクとか、IOとか。

なかださんがおっしゃるように1.8からは正式にサポートされます
し、1.6.8版も(unofficialですが)存在します。
  http://www001.upp.so-net.ne.jp/konishi/ruby/index.htm

それでは。
-- 
U.Nakamura <usa / osb.att.ne.jp>