あおきです。

  In Mail "[ruby-ext:00175] ruby/gtk pre0.17"
    Dai <MAP2303 / mapletown.net> wrote:

>   神田@楓街です。
> 
>   結局パッチワークになっちゃいましたけど、Gtk+-1.2.x 対応の ruby/gtk です。
>   附属のサンプルは確認しましたが、たぶんバグ在り。乞うテスト。

コンパイルは通ったのですが、起動に失敗しました。

  ruby sample/drawing.rb

とすると、

  unresolved simbol --- Init_gtk_gdkkeysyms()
  ...

となります。
src/Makefileを以下のように変えたら通りました。

--- Makefile.org	Sat May 15 16:06:03 1999
+++ Makefile.new	Sat May 15 16:06:32 1999
@@ -22,7 +22,7 @@
 
 LOCAL_LIBS = 
 LIBS = -lgtk -lgdk -lglib -lXi -lXext -lX11 -rdynamic -lgmodule -ldl -lm -lc
-OBJS = init.o global.o librbgdkkeysyms.a rbgdk.o rbgtk.o  
+OBJS = rbgdk.o rbgtk.o init.o global.o librbgdkkeysyms.a
 
 TARGET = gtk
 DLLIB = $(TARGET).so


環境は
  Linux 2.0.36
  libc.so.5.4.44
  ld-linux.so.1.9.9
  glib-1.2.2
  gtk+-1.2.2
  ruby 1.3.3 (19990513)
です。
-------------------------------------------------------------------
あおきみねろう  mail: aamine / dp.u-netsurf.ne.jp
                site: http://www1.u-netsurf.ne.jp/~brew/mine/