中村 のりつぐ です。

In article <199905101952.MAA12391 / proxy4.ba.best.com> 
Toru Hoshina <hoshina / best.com> wrote:
> だもんで、不毛かも知れぬとは思いつつ、強引に ruby 1.2.5 で make できる
> ように patch を作ってしまいました。ruby-gtk-0.16 と pre0.17 を比較して
> GTK+ そのものに関連する部分以外を ruby-gtk-0.16 相当に戻しただけ(汗)です。

gtk+-1.2.2 にしている Solaris マシンがあったので
 ruby 1.2.5 で試してみました。

コンパイルしたら、
  ld: fatal: too many symbols require "small" PIC references:
  	have 3317, maximum 2048 -- recompile some modules -K PIC.
と言われたので、 -fpic を -fPIC に変更してコンパイルして
 helloworld.rb が動作するのを確認しました。

# 最近 Rb という文字を見ると REALbasic に見えるぞ

       中村 典嗣  E-mail:     nnakamur / mxq.mesh.ne.jp