立石です.

At Fri, 27 Jul 2001 16:41:23 +0900,
matz / ruby-lang.org (Yukihiro Matsumoto) wrote:
> で、個人的にはPtrDataとStructDataのクラスを分けない(ので結果
> としてキャストが不要)というアプローチの方が良いのではないか
> と思います。もちろん、単なるポインタからみればStructDataには
> 不要なメソッドがいっぱいあるわけですが、それはそれ、その不要
> なメソッドの呼び出しを禁止してしまえば実害は無いのではと。

なんだか一緒にしてしまった方がよいような気がしてきました.
特に,ライブラリとしてもPtrData一つにしてしまった方が考え
る点が少なくなるので一緒にしてしまおうと今のところ思ってい
ます.

# 分ける利点というのもそんなに大きなものではないですし…
-- 
Takaaki Tateishi <ttate / jaist.ac.jp>