保科です。

On Mon, May 10, 1999 at 12:13:55PM -0400,
kikutani / sprintmail.com wrote:

> 4. どっちでもmakeできるようにする。
略
> とかやって、どっちでもmakeできるようにした記憶がありますが、
> これは難しいですか?

これが一番嬉しいです。私も rskkserv とか mailclient とか RuBBS とか(笑)
その他、こまごまと ruby 1.2.5 を使っているので、楽しみにしていたとはいえ
ruby/gtk のために ruby 1.3 系に移行するのはちょっと… どれも動作する
のでしょうけども。

だもんで、不毛かも知れぬとは思いつつ、強引に ruby 1.2.5 で make できる
ように patch を作ってしまいました。ruby-gtk-0.16 と pre0.17 を比較して
GTK+ そのものに関連する部分以外を ruby-gtk-0.16 相当に戻しただけ(汗)です。

http://www.best.com/~hoshina/packages/ruby-gtk-pre0.17-to-r1.2.patch.gz

です。五十嵐さんのrbgtk.c に対するパッチまでは含んでいます。また
赤帽な人は ruby-gtk-0.17pre-1.src.rpm とかも同じところにあったり(汗)

とりあえず動いてはいるようなのですが…

-- 
ちなんでどうする気だ?

保科 徹(hoshina / best.com)  http://www.best.com/~hoshina
PGP fingerprint : 95 73 1C 26 C6 9E 28 86  BA 32 34 CA FC 9B DC 6D