まつもと ゆきひろです


In message "[ruby-cvs] rough/ext/digest: Say hello again to OO, and good-bye to old fashioned excessive macros"
    on 01/07/11, knu <cvs-admin / ruby-lang.org> writes:

|  Modified files:
|    rough/ext/digest:
|      digest.c
|  Log:
|    Say hello again to OO, and good-bye to old fashioned excessive macros
|    of C.  Now all the Digest::ALGO classes are subclasses of Digest::Hash
|    which is newly created to unify the duplicate code.

この変更には賛成ですが、Hashでない名前の方があとあと問題を起
こしにくいと思いますよ。まあ、::Hashでアクセスできるんで、思
いつかなければそのままでよいのですが。