On Mon, 10 May 1999 23:07:41 +0900,
Dai  wrote:

> > Gtk+-1.2.x対応のruby-1.2用という計画はないのですか?
> > 
> > これのために1.3に移行するのもめんどうだなあ。
> 
>   基本的に rename.rb したくらいですから、すぐにでも作れそうです:)
>   どういうリリース形態がいいでしょう?
> 
>   1. ruby-gtk-x.xx-1.2.tar.gz, ruby-gtk-x.xx-1.3.tar.gz
>   2. ruby-gtk-x.xx.tar.gz に 1.2 用のソースを含めておく。
>   3. ruby-gtk-x.xx-tar.gz に 1.2 用への変換スクリプトを含めておく。

4. どっちでもmakeできるようにする。

slanglibでは

#ifdef str2cstr
#define TRUE 2
#define FALSE 0
#define cObject rb_cObject
    .....
    .....
#endif

とかやって、どっちでもmakeできるようにした記憶がありますが、
これは難しいですか?

-- 
Kikutani, Makoto  kikutani / sprintmail.com