まつもと ゆきひろです

In message "[ruby-ext:01816] Re: call for review: ext/digest module"
    on 01/07/06, "Akinori MUSHA" <knu / iDaemons.org> writes:

|> 標準導入には全く文句ないんですが、単に'digest'でいいんですか
|> ねえ(また、名前か...)。なんかいろんな意味に取られそうですが。
|> もっとも、使ったもん勝ちというも確かなんですが。
|
| Perl では Digest::MD5 という階層になっているので、 digest と
|いえばメッセージダイジェストかな、という刷り込みがありました。 ;)
|NetBSD 方面には md5/sha1/rmd160 を統合した digest(1) というのも
|あるので。(FreeBSD ports にも入っています)
|
| しかし、現在の(仮称) digest モジュールでは特に Digest という
|名前空間 (module) を定義しているわけではないので、モジュールの
|名前は何でも構いません。適度に短くて分かりやすいものがあれば
|採用したいですね。

いや、別に変える必要はないんですよ。重要なのはいろいろ考える
ことで、結果として digest になるのは問題ないと思います。

でも、名前空間とライブラリ名は違わない方が嬉しいかも。

module Digestを定義して md5.rb は

  require 'digest'
  MD5 = Digest::MD5 

にするという選択肢もありえますね。

                                まつもと ゆきひろ /:|)