まつもと ゆきひろです

In message "[ruby-ext:01795] Re: Ruby/SDL on PS2 LinuxKit"
    on 01/06/26, Takahiro Kambe <taca / sky.yamashina.kyoto.jp> writes:

|>   generic wrapper -> system dependent
|> 
|> という使われ方が多いからです。ですから、
|なるほど。
|
|foo.rbとfoo.soの両方を使うのが根本的にいけない?

「いけない」ってことはないでしょう。基本的な機能だけ拡張ライ
ブラリで提供して、あとその組み合わせで済むものはRubyで書くと
いうのは自然なことだと思います。

|> でした。なんでこんな変なパスなの?
|これは、まつもとさんお使いのLinuxのディストリビューションでperlのパッ
|ケージを作った人の問題では??

そうでしょうね。いや、その人はなにを思ってそういうconfigにし
たのかな、ということ。

|pkgベースのNetBSDでは、
|
|    /usr/pkg/lib/perl5/5.6.1/i386-netbsd
|    /usr/pkg/lib/perl5/5.6.1
|    /usr/pkg/lib/perl5/site_perl/5.6.1/i386-netbsd
|    /usr/pkg/lib/perl5/site_perl/5.6.1
|    /usr/pkg/lib/perl5/site_perl
|    .
|
|となってます。あ、site-perlが後なんだ...。今の今まで知らなかった(気に
|してなかった。)

標準があまり変化すべきでないという観点からは神戸さんの指摘の
逆順が実は望ましい順序なのかもしれませんね。うーむ。

                                まつもと ゆきひろ /:|)