yoshi@giganetです。

On Sun, 29 Apr 2001 21:24:22 +0900, WATANABE Hirofumi <eban / os.rim.or.jp> wrote:
>わたなべです.
>
>Yoshiyuki Kusano <yoshi / giganet.net> writes:
>
>:私の方で、cygwinでのextconf.rbがなんでだめなのか確かめてみようかと
>:思ったのですが、ruby-1.6.3のコンパイルに四苦八苦してます。
>
>最新のCygwinのバージョンだとruby-1.6.3はコンパイルできないので、
>Rubyのほうも最新にしてください(CVSとかsnapshotとか)。

入っていたcygwinを調べてみたら1998/12/10になってました。
ですので、私の場合、cygwinが古すぎるみたいですね。

>:で、もしどなたかよろしければ、Windows環境(cygwin or VC6)で
>:OpenGL Interfaceがコンパイルできるか確認してもらえませんか?
>:それで、修正等が必要であれば教えていただけないでしょうか?
>
>とりあえずこんな感じで。
>have_libraryにもheaderを指定できないと無理があるなあ。
>CygwinのGL/gl.hではなぜかGL_VERSION_1_2がdefineされてるけど
>実際は1.1です。

あ、そういうことですか。
いわれてみると確かに1.2のAPIがリンクできてないですね。

ありがとうございました。