だいです。

Re the message of ``[ruby-ext:01577] Re: require 'dir/...'?''...

○あおきさん:
> あおきです。

> あれ? ちょっと待てよー。ということは ls *.rb > all.rb すれば
> 自動更新できる? うーん…でも何回も require するのってちょっと
> 汚いような…これじゃ理由としては弱いなあ…あきらめようなかあ…(弱気)。

  Dir.glob(*.rb).each { |lib| require lib } でいいのでは?

  Dir は何か一工夫必要ですが。