石橋秀仁です。おひさしぶりです。

Masaki Suketa <CQN02273 / nifty.ne.jp> wrote:

> >     RUNIT::Assert#assert_test(obj1, op, obj2 [,message])
> > 
> >     !obj1.send(op, obj2) のときに RUNIT::AssertionFailedError
> >     例外を発生させる。第 3 引数が指定された場合は、 message
> >     文字列とともに例外を発生させる。(別名: assert_comparison)
> 
> これ、いいですね。取り込ませていただきます。
> 
> が、assert_testという名前はちょっと一般的過ぎるので
> もうちょっとぴったり来る名前をつけたいところです。
> 逆にassert_comparisonは用途が限定され過ぎるイメージがあるので
> ちょっと。
> 
> って思ったのですが、op は <=> みたいな奴じゃなくてどんな
> メソッドでもいいのか。うーむ。
> assertの代わりに使えるのだから、assert_testでいいのか。
> 
> もうちょっとだけ名前を考えさせて下さい。

「演算子」とか
assert_operator
assert_operator_method

「Lisp の p」とか
assert_proposition
assert_proposition_method

「ブール代数値」とか
assert_boolean
assert_boolean_method

どうでしょう?


--
Hideto "rubyholic" ISHIBASHI  http://www.rr.iij4u.or.jp/~hideto-i/