助田です。 こっちにも来てたんですね。
同じ内容になりますが。

In message "[ruby-ext:01456] RUNIT::Assert#assert_test"
    on 00/12/17, "Akinori MUSHA" <knu / iDaemons.org> writes:

>  Perl/Ruby Con. で Advanced Ruby を聴講させていただきましたが、
> おかげで少し躊躇していた XP の段階的な導入に踏み切る勇気が出ました。
> 実践的で分かりやすいプレゼンテーションをありがとうございました。

そうおっしゃっていただけるとありがたいです。
こちらこそ、滅多にない貴重な経験ができ、非常に有意義な時間
だったとみなさんに感謝してます。

>     RUNIT::Assert#assert_test(obj1, op, obj2 [,message])
> 
>     !obj1.send(op, obj2) のときに RUNIT::AssertionFailedError
>     例外を発生させる。第 3 引数が指定された場合は、 message
>     文字列とともに例外を発生させる。(別名: assert_comparison)

これ、いいですね。取り込ませていただきます。

が、assert_testという名前はちょっと一般的過ぎるので
もうちょっとぴったり来る名前をつけたいところです。
逆にassert_comparisonは用途が限定され過ぎるイメージがあるので
ちょっと。

って思ったのですが、op は <=> みたいな奴じゃなくてどんな
メソッドでもいいのか。うーむ。
assertの代わりに使えるのだから、assert_testでいいのか。

もうちょっとだけ名前を考えさせて下さい。

# 多分メール頂いても返事できるのは、来年になると思いますので
# 返事遅くてもご容赦下さい。
  
  助田 雅紀 <CQN02273 / nifty.ne.jp>