まつもと ゆきひろです

要するにTkRadioButtonはTkRadiobuttonという名前にならないだろ
うか(Perl/Tkとの互換性のためにも)という提案です。もちろん古
い名前は別名として残すわけです。

  TkRadioButton = TkRadiobutton

あるいはその逆をtk.rbのどこかにいれるだけのことですが、どう
思いますか?

------- Start of forwarded message -------
Date: Mon, 6 Nov 2000 17:59:04 +0900
Posted: Mon, 6 Nov 2000 02:58:51 -0600
From: "Conrad Schneiker/Austin/Contr/IBM" <schneik / us.ibm.com>
Reply-To: ruby-talk / netlab.co.jp
Subject: [ruby-talk:6076] Ruby/Tk GUI question: TkRadioButton versus TkRadiobutton
To: ruby-talk / netlab.co.jp (ruby-talk ML)

Hi,

While using the SpecRuby GUI builder 
(http://www.ruby-lang.org/en/raa-list.rhtml?name=Ruby%2FTk+GUI+builder+--+specRuby),
I discovered that I get:

    untitled.ui.rb:17:in `untitled_ui': uninitialized constant 
TkRadiobutton (NameError) ....

because Ruby/Tk wants TkRadiobutton.new to be referred to as 
TkRadioButton.new instead.

Since you hopefully :-) want this to be (1) Ruby/Tk versus 
Ruby/95%-almost-Tk, and since (2-a) the "Programming Ruby" book documents 
Ruby/Tk in terms of translations from Perl/Tk documentation (the big 
Perl/Tk book uses lowercase b) and (2-b) specPerl uses Radiobutton too, 
can this be changed in 1.6.2? 

If so, it might also be a good idea to add an alias for the old way 
(perhaps with a warning) so that old code, e.g. the widget demos 
(http://www.ruby-lang.org/en/raa-list.rhtml?name=Ruby%2FTk+Widget+Demos), 
will still run for the time being.

Conrad Schneiker
(This note is unofficial and subject to improvement without notice.)
------- End of forwarded message -------