福嶋です。

At Mon, 11 Sep 2000 05:09:50 +0900,
Akinori -Aki- MUSHA <knu / idaemons.org> wrote:
>  Ruby/Python の extconf.rb は現在 Python 1.5 決め打ちになって
> いますが、任意のバージョン、もしくはパスを指定できるように改良
> してみました。

ありがとうございます。

> と言われてうまく動きませんでした。C インターフェースの変更に
> 追従する必要がありそうです。

そうですね。
というか、私の方ではpython1.6ですら、まだテストしていないという状態
なんです…

> 
>  また、 Python を pthread サポート付きで作ったときのために
> Ruby/Python も pthread 付きでビルドできるようにするノブを付けて
> みました。

2つほど質問させて下さい。

1. できるだけ個別の対応はしたくないので、リンクに必要な情報は
pythonがビルドされた時のMakefileから持ってくるようにしているのです
が、その方法では対処不可能なのでしょうか。

2. これは libpython に固有の問題でしょうか。それとも他のライブラリ
でも発生する可能性がある問題なのでしょうか。言い換えれば、
Ruby/Python の extconf.rb で対処すべきなのか、mkmf.rb で対処すべき
なのかということです。

---
福嶋正機