福嶋です。

Yukihiro Matsumoto <matz / zetabits.com> wrote:
> In message "[ruby-ext:01258] Ruby/Python doesn't work with Ruby 1.6"
>     on 00/09/10, "Akinori -Aki- MUSHA" <knu / idaemons.org> writes:
> | 今日も引き続き Ruby 1.6 での各種モジュールの動作チェックを
> |やっているのですが、 Ruby/Python が Ruby 1.6 でうまく動かない
> |のを見つけました。

> rb_obj_equalは昔から(1.4.0の頃から)staticです。なぜ1.4.0で呼
> べるのか理解できません。rb_obj_equalはポインタ値を比較してる
> だけですから、Cの==で代用できます。

うーむ、確に自分でも、なんでこんな風になってるのか思い出せません。
とりあえず、この点以外にも、1.6.0対応の修正をしたバージョンを出しま
した。お試し下さい。

http://www.goto.info.waseda.ac.jp/~fukusima/ruby/ruby-python-0.3.3.tar.gz

---
福嶋正機