Wed, 06 Sep 2000 03:11:19 -0400 頃の
   Mail-Count: 01244
      Subject: [ruby-ext:01244] Re: Ruby/GTK-0.23 & ruby-1.6.0-preview & progressbar   
についてのお話にて Yasushi Shoji さん曰く… 
(Y == Yasushi Shoji <yashi / yashi.com> さん)

In article 01244, <20000906031119D.yashi / yashi.com>
Y> 三日ほど五十嵐さんが mailを読めないらしいので、戻られるまで話の続きを‥

ども. 

>>    libgtk-ruby        (libgtk-imlib-ruby と conflict)
>>    libgdk-pixbuf-ruby (libgtk-ruby に depend, 
>>                        libgdk-imlib-ruby と conflict)
>>    libgdk-imlib-ruby  (libgtk-ruby の depend,
>>                        libgdk-pixbuf-ruby と conflict)
Y> 
Y> gdk-imlibと gdk-pixbufは conflictしてはまずいかと思います。さすがに両方
Y> 同時に使ってる applicationは見たことないですが、compile timeで選べたりと
Y> かどちらかを使ってるもの達が混在してるのが現状かと。

なるほど. 

Y> gdk-pixbufは Gnome 2.0の前は additionalです。

そうですね. 
pixbuf と imlib が conflict すると思い込んでいたため
このようにしてしまってました. 

>>    libgnome-ruby      (ligdk-imlib-ruby か libgdk-pixbuf-ruby に depend)
Y> Gnome 1.2では、libgnomeは gdk-pixbufには依存しません。ただ、libgnome*を
Y> 使ってる applicationが gdk-pixbufを使う事は可能ですが‥。

了解です. 

>>  Gtk+ 2.0 以後:
>>    libgtk-ruby        (機能的には旧 libgtk-ruby + 旧 libgdk-pixbuf-ruby)
>>    libgnome-ruby      (新 libgtk-ruby に depend)
Y> で、今度は gdk-imlibが additionalになるかも(と言うかあっても conflictし
Y> ないはず)

ふむふむ. 

Y> いちおうまとめ
Y> 
Y> Name(dependency)  # comment
Y> 
Y> 現在
Y>        libgtk-ruby(libgtk, ruby)
Y>        libgdk-imlib-ruby(libgtk-ruby)
Y>        libgnome(libgdk-imlib)
Y> 
Y>        libgdk-pixbuf-ruby (libgtk-ruby) # additional
Y> 
Y> Gtk+ 2.0
Y>        libgtk-ruby(libgtk, ruby)        # 旧libgdk-pixbuf-rubyを含む
Y>        libgnome(libgtk-ruby)
Y> 
Y>        libgdk-imlib-ruby(libgtk-ruby)   # additional

ありがとうございます. これでパッケージは作れそうです. 

あとはバージョンがどうなるかっていうあたりと
0.24 pre 的にあつかってもいいいのかどうかというあたりが
懸案事項ってことになりそうです. 

-- 

 やまだ あきら <URL:http://arika.org/>
 (akira / arika.org, akira / ruby-lang.org or akira / ad-hoc.org)