なひです.

> From: TAKAHASHI Masayoshi [mailto:maki / inac.co.jp]
> Sent: Friday, December 24, 1999 8:51 PM

> # あとはURIクラスさえなんとかなれば……。

uri.rbの2000.01.19バージョンを試してみました.
http://www02.so-net.ne.jp/~greentea/ruby/uri/
説明のところの「URIParser」ってなんでしょう?

2個所ほどPatchです.
前者はどうするのが美しいかな...
正規表現の()?は,nilだったり""だったりするので困りますね.

--- uri.rb.dist	Wed Jan 19 19:29:44 2000
+++ uri.rb	Wed Jan 19 19:53:05 2000
@@ -182,9 +182,9 @@ module URIModule
 	raise ArgumentError('bad URI: ' + uri)
       end
-      scheme = $2
-      authority = $4
-      path = $5
-      query = $7
-      fragment = $9
+      scheme = ( $2 and $2.empty? )? nil : $2
+      authority = ( $4 and $4.empty? )? nil : $4
+      path = ( $5 and $5.empty? )? nil : $5
+      query = ( $7 and $7.empty? )? nil : $7
+      fragment = ( $9 and $9.emtpy? )? nil : $9
       if authority and X_REG_NAME !~ authority
 	raise ArgumentError, 'bad authority'
@@ -203,5 +203,5 @@ module URIModule
 	raise ArgumentError, 'bad fragment'
       end
-      [scheme, authority, path, fragment, query]
+      [scheme, authority, path, query, fragment]
     end