あおきです。

  In mail "[ruby-dev:8814] Re: [REQ] Array#each{|a,b,...|}, Array#shift/pop(num)"
    matz / netlab.co.jp (Yukihiro Matsumoto) wrote:

> まつもと ゆきひろです

> sliceは良いかも。ちょっと考えさせてくださいませ。
> 他の方の意見も歓迎します。
> 
> この場合、delete_atはどうします?

西さんへの返事を書いている最中で、やっぱり delete_at( i, len ) も
欲しいと思いました。
それで提案なんですが、delete_at( i, len ) を self かなにかを返すように
実装して、slice! を返り値も返す版にしたらどうでしょうか?
delete_at(i) は現在の仕様のままで、ドキュメントからは返り値の記述を外す。
で、slice!(i) を許すようにして破壊的取り出しはこっちに揃えればばっちり。

唯一の弱点は slice!( i ) の意味がわかりにくいことなんですけど…
-------------------------------------------------------------------
あおきみねろう