ごとけんです

In message "[ruby-dev:8816] Re: [REQ] Array#each{|a,b,...|}, Array#shift/pop(num)"
    on 00/01/04, Yukihiro Matsumoto <matz / netlab.co.jp> writes:

>  res <<< foo <<< value
>
>
>
>  res = foo; foo = value
>
>という意味だけだったとしてですが。

取り下げたのにナンですが、確かに、

res = a[*ind]; a[*ind] = value

が

res <<< a[*ind] <<< value とかけてもいまいちかも知れませんが、
buf が未使用かどうか不明の場合、

prev <<< buf <<< a[*ind] <<< value

とかいうのが書けるので結構いいかなとは思ってます。

まぁしかしこれだけだとあまりに説得力ないのも自覚してまする。

-- gotoken