有馬です。

matz / netlab.co.jp (Yukihiro Matsumoto) wrote

| |そのかわりに、破壊的抽出のみを行う Array#exclude を提案します。
| 
| |名前は exclude でなくてもいいですが、
| |こういう働きをするメソッドはぜひ欲しいです。
| 
| そのようなメソッドに賛成します。が、excludeってなんか違う気
| がする。良い名前募集。ruby-talkで聞くべきか。

英語のセンスには自信がないですが pick/pickup/extract はどうでしょう。

--
 有馬 康弘 <fit0298 / fitec.co.jp>