なかだです。

At Wed, 29 Dec 1999 12:14:37 +0900,
matz / netlab.co.jp (Yukihiro Matsumoto) wrote:
> |>    (a) その要素を追加する
> |>    (b) その要素のto_aと結合する(現状)
> |>    (c) エラー
> |
> |くりかえしになりますが、これについては (c) が妥当だと思いま
> |す。一番大きな理由は配列以外を引数にしたときの挙動はそれほど
> |自明ではないことです。
> 
> 決めれば良いのだと思いますけどね。
> (b)は便利なようなそうでないような。
> 
> (a)は右辺が配列かどうかで挙動が変化するのであんまり良くない
> ですね。となると、やっぱり(c)かなあ。

  私なんてずっと (a) だと思い込んでました。
# 無知(^^;;

  というか、いつも Array#<< を使ったり String#split してから足し
たりしてるようで、そういうシチュエーションで使ったことがなかった
みたいな。

  ということで(何が?)、(c) かなぁ。

> |>    (g) str.collect{|s|s}相当(現状)
> |>    (h) str が$/を含まないとき [str]、含むときstr.collect{|s|s}
> |>    (i) いつも [str]
> |
> |(h) も捨てがたいですが、モデルが複雑になるので (g) のままが
> |よいような気もします。
> 
> (g)はやめようと思ってます。あとは(h)か(i)かですが、モデルが
> 単純と言う観点では(i)がベストですよね。どうしよう。

  String#each_line の動作からすると、$/ を含むかどうかよりも空文
字列でないかどうかのように思えますが。

-- 
そうだ 強気に ちょっと インチキに☆彡
    中田 "Bugるくらいがちょうどいいかも;-)" 伸悦