青山です。

On Fri, 3 Dec 1999 23:47:00 +0900,
Wakou Aoyama <wakou / fsinet.or.jp> wrote:

> raise "Please, use ruby1.4.3 or later." if MOD_RUBY and (RUBY_VERSION < "1.4.3")
> 
> こんな感じで 1.4.3 より前の物は cgi.rb の読み込み時に落してしまっても
> 良いでしょうか?  無視して at_exit を登録してもどうせ落ちますし、場合
> 分けして at_exit を使わないようにしても例の POST 時に複数の CGI オブジェ
> クトを生成すると止まりますから、1.4.3 へのアップデートを必須としてしまっ
> ても良いようには思いますが、いかがでしょう。

特にコメントが付かないようですし、何より、次に Ruby 本体と一緒に配布さ
れる時には当然ながら 1.4.3 と一緒という事になりますから、考えてみれば
無用な心配のようにも思えてきました。

という事で、上記の例のように mod_ruby 上では 1.4.3 以降を必須として
cgi.rb-1.10.gz を in.coming に入れて置きました。また、nif.rb-0.91.gz
も置きましたので、よろしくお願い致します。nif.rb, nif.rb-0.90.gz は消
して下さい。

ruby_ppc_test.tar.gz も消して下さい。MachTen 上での動作テスト用のもの
でしたし、ruby1.1a9 とかなり古いものですから、もしバイナリセットで置き
直すにしても、1.4 系にすべきでしょう。

(そういえば、MachTen のバージョンアップもしていなかった。しかし、もう
Mac 上で unix を使う事は無いかな。結構高いし>MachTen)


-- 
青山 和光 Wakou Aoyama <wakou / fsinet.or.jp>