青山です。

On Wed, 1 Dec 1999 22:20:31 +0900,
Wakou Aoyama <wakou / fsinet.or.jp> wrote:

> > 今 commit してる 1.5.0 でもおおよそ大丈夫だと思います。
> 
> 1.4.3 も大丈夫のようですね。

1.5 系は開発版かつ入手経路 cvs のみという事で RELEASE_DATE 等での振り
分けはしないとして、1.4 系はどうしましょうか?

raise "Please, use ruby1.4.3 or later." if MOD_RUBY and (RUBY_VERSION < "1.4.3")

こんな感じで 1.4.3 より前の物は cgi.rb の読み込み時に落してしまっても
良いでしょうか?  無視して at_exit を登録してもどうせ落ちますし、場合
分けして at_exit を使わないようにしても例の POST 時に複数の CGI オブジェ
クトを生成すると止まりますから、1.4.3 へのアップデートを必須としてしまっ
ても良いようには思いますが、いかがでしょう。


-- 
青山 和光 Wakou Aoyama <wakou / fsinet.or.jp>