けいじゅ@日本ラショナルソフトウェアです.

In [ruby-dev :8487 ] the message: "[ruby-dev:8487] Re: [REQ]
{enumerable, integer, range}.rand ", on Dec/02 12:25(JST) Yukihiro
Matsumoto writes:

>まつもと ゆきひろです

>|逆に、まつもとさんは「組み込みの定義は少ない方がよい」と考えられ
>|ている気がするのですが、もしそうであれば、その理由は何なのでしょうか?
>
>というのは多分誤解です。ただ、私は
>
>  * 今回rand/randomという名前が適切だと思ってない(機能と名前
>    が一致していると思わない)

  Array#some
  Array#someone
  Array#somebody
  Array#some_element

とかはどうです? 

こういうメソッドが標準でついている言語を見た覚えがあります.

# ただ, 定義は最初の要素を返すものだったと思いましたが(^^;;;

>  * 自分が十分納得してない名前のメソッドを導入すると後でいろ
>    いろもめたり、悩んだりする
>
>という理由からやや保守的になりがちなのですよ。

名前の案を出していて何ですが, 正直言ってあまり必要性は感じていませんが
(^^;;;

__
..............................石塚 圭樹@日本ラショナルソフトウェア...
----------------------------------->> e-mail: keiju / rational.com <<---