まつもと ゆきひろです

In message "[ruby-dev:8468] require で SEGV"
    on 99/12/01, ruby <g96p0935 / mse.waseda.ac.jp> writes:
|ぐはぁ(吐血)
|もう報告されたかもしれませんが、以下のスクリプトで SEGV ります。
|DLEXT は ".so" です。どうやら GC で死んでいるみたいです。
|1.4.2です。

バグです。パッチはこんな感じ。

--- /tmp/eval.c	Thu Dec  2 10:45:01 1999
+++ eval.c	Thu Dec  2 10:45:06 1999
@@ -7348,7 +7348,7 @@
     const char *feature;
 {
     if (loading_tbl) {
-	st_delete(loading_tbl, feature, 0);
+	st_delete(loading_tbl, &feature, 0);
     }
 }