こんばんは、ZnZです。

On [Wed, 17 Nov 1999 16:15:51 +0900]
matz / netlab.co.jp (Yukihiro Matsumoto) wrote:
> そういう意味です。ちょっときれいじゃないですよね、文法が。
> 
>   begin
>   rescue Errno::ENOENT, Errno::EINVAL(err)
>   end
> 
> じゃなんだか分からないし。
> 
>   rescue Errno::ENOENT, Errno::EINVAL => err
> 
> ?? うーむ。

rescue(err) Errno::ENOENT, Errno::EINVAL

というのを思いつきましたが、
イテレータみたいに|err|の方がいいかも。

rescue |err| Errno::ENOENT, Errno::EINVAL
rescue Errno::ENOENT, Errno::EINVAL |err|

どうでしょうか?

--- 
ZnZ(ゼット エヌ ゼット)
西山和広(Kazuhiro Nishiyama)
mailto:nishiyama / mx1.tiki.ne.jp