まつもと ゆきひろです

In message "[ruby-dev:5171] Re: a genericity"
    on 99/02/17, 石塚圭樹 <keiju / rational.com> writes:

|えーと. ですね. 提案なんですが, どちらにしても新しい coerceはRuby-1.3
|及びRuby-2.0に採用されることはないと思います. 

Ruby 2.0の話が出ましたが,最近まで今の1.3が安定したら2.0にし
て,Ruby本の対象とすると発言してきました.ご存じない方もいらっ
しゃるでしょうが.

しかし,現在Ruby本に取り込めないから大きな変更をしたくないと
いう理由でペンディングにしている機能がいくつかあり,

  * キーワード引数
  * finalize
  * 新coerce

また,Ruby本で扱っている仕様は1.1の頃から大差ないことを考え
ると2.0というのは大袈裟な気がしてきました.Ruby本の対象は1.4っ
てんでどうでしょう? > 石塚さん

で,その後みんなで2.0の仕様を考えるっていう楽しいフェーズに
突入するというのはいかがでしょう?

                                まつもと ゆきひろ /:|)