Issue #17572 has been updated by nagachika (Tomoyuki Chikanaga).

Backport changed from 2.5: REQUIRED, 2.6: REQUIRED, 2.7: REQUIRED, 3.0: DONE to 2.5: REQUIRED, 2.6: REQUIRED, 2.7: DONE, 3.0: DONE

ruby_2_7 4b6df7f735c10f326f09a44fe38dc10b05ced21c merged revision(s) a55eb9a2af7950d180d9d31ffde2bce66710f44f.

----------------------------------------
Bug #17572: coerceで作成した(0.0/1)を計算に用いるとコアダンプする
https://bugs.ruby-lang.org/issues/17572#change-90345

* Author: freedom (free dom)
* Status: Closed
* Priority: Normal
* ruby -v: ruby 3.0.0p0 (2020-12-25 revision 95aff21468) [x86_64-linux]
* Backport: 2.5: REQUIRED, 2.6: REQUIRED, 2.7: DONE, 3.0: DONE
----------------------------------------
coerceで`(0.0/1)`等の値を作成することができ、こちらを計算に使用するとコアダンプして落ちます(出力は添付参照)

再現コード

``` ruby
1/0r.coerce(0.0+0i)[0]
```

よろしくおねがいします

---Files--------------------------------
coredump (19 KB)


-- 
https://bugs.ruby-lang.org/