Issue #17572 has been updated by naruse (Yui NARUSE).

Backport changed from 2.5: REQUIRED, 2.6: REQUIRED, 2.7: REQUIRED, 3.0: REQUIRED to 2.5: REQUIRED, 2.6: REQUIRED, 2.7: REQUIRED, 3.0: DONE

ruby_3_0 d370cb62d26f212e431d4a7b38db56254c95cd5d merged revision(s) 9efd590a13d1e8b8a141c46eabb48c2a1c286d2b,a55eb9a2af7950d180d9d31ffde2bce66710f44f.

----------------------------------------
Bug #17572: coerceで作成した(0.0/1)を計算に用いるとコアダンプする
https://bugs.ruby-lang.org/issues/17572#change-90241

* Author: freedom (free dom)
* Status: Closed
* Priority: Normal
* ruby -v: ruby 3.0.0p0 (2020-12-25 revision 95aff21468) [x86_64-linux]
* Backport: 2.5: REQUIRED, 2.6: REQUIRED, 2.7: REQUIRED, 3.0: DONE
----------------------------------------
coerceで`(0.0/1)`等の値を作成することができ、こちらを計算に使用するとコアダンプして落ちます(出力は添付参照)

再現コード

``` ruby
1/0r.coerce(0.0+0i)[0]
```

よろしくおねがいします

---Files--------------------------------
coredump (19 KB)


-- 
https://bugs.ruby-lang.org/