こんにちは、なかむら(う)です。

In message "[ruby-dev:51000] 2.7までで動いていたが3.0でエンコードのエラーになる"
  on Thu, 28 Jan 2021 23:28:36 +0900, paptimusx / gmail.com wrote:
> Windows10  (64ビット,日本語環境,cp932)
> 2.7までで動いていたが3.0でエラーになるようになった
> 2.7,3.0 ともchocolatelyで入れたもの
> エンコーディングの仕様が変わったのでしょうか

3.0より、Windowsにおいてdefault external encodingはUTF-8となりました。
なので、


> $ cat a.rb
> #!/usr/bin/ruby
> #; coding: cp932
> files = ARGV
> 
> for file in files
>   $stderr.print "[#{file}]\n"
>   fin = open(file, 'r')

ここで encoding: 'cp932' あたりを指定してください


それでは。
-- 
U.Nakamaura <usa / garbagecollect.jp>